Belief and Decision Networks

Back to help contents.

dot Creating A Network

There are two ways to create a problem in the Belief and Decision Network Applet.

  1. Load A Sample Graph

    This is the way to load a prebuilt Bayes graph or Decision network. You can load from a set of sample problems, or load from a URL.

    • On the menu bar, select File->Load Sample Graph. A dialog will pop up with a choice of sample problems. Choose one.

    • On the menu bar, select File->Open Location. Type in the URL of the graph, and click load.

  2. Create a network manually

    Click the Create mode tab to display the Create panel. Click on the Create Node button and then click on the canvas. A dialog will pop up to ask the user what the node's name is and what is the domain of the node. Click 'Done' to create the node. Place additional nodes in this manner. To create arcs, click the Create Arc button and click on a node to define the starting point of that arc. Click on another node to define the end point of that arc. Arcs define probabilistic dependencies. To modify a node's probabilities, click the Modify Probability Table button and click on the node to be modified.

    If the user wants to create a Decision Network (as opposed to a Belief Network), go to Network Options->Belief/Decision Mode and select Decision Network Mode. This will allow the user to set the node type as normal, decision, or utility while creating nodes.

dot Solving A Problem

Click the Solve mode tab to go to Solve mode. Click the Query Node button. If the network is a Belief Network, one can query nodes immediately. However, if it is a Decision Network, some nodes (particularly decision nodes) cannot be queried until the network is optimized. Clicking on the Optimize Decisions button will optimize the decision nodes.

There are two ways to solve a query. To switch between modes, go to Network Options->Query Modes, and select either Brief Query Mode, Verbose Query Mode, or Prompt For Query Mode. If Prompt For Query Mode is selected, every time a query or optimization problem is solved, a dialog will pop up prompting the user to select either Brief or Verbose Query mode.

  1. Brief Query Mode. Just click on a node after depressing the Query Node button. This will solve for the probabilities of the domain of the node, and will pop up a dialog informing the user of the results of the query.

  2. Verbose Query Mode. Clicking on a node after depressing the Query Node button will pop up a new canvas where the user can manually do variable elimination.

Valid HTML 4.0 Transitional