General Help
STRIPS to CSP converter

Back to help contents.




Create Mode

Solve Mode

dot Overview

A problem, or STRIPS problem, is a problem which can be expressed as a set of variables, each with a particular domain, a set of actions, each with a pre and post condition, and a start and goal state, each state being a partial assignment of values to variables. A solution to a STRIPS problem is a series of actions that lead from the start state to the end state.

This applet is designed to let you create such a problem and solve by converting the problem into a CSP problem and solving it with one of the applets designed to do so.

dot Menus

File Menu

  • Create New STRIPS- Discard the current STRIPS problem and start creating from an empty problem.
  • Load Sample STRIPS - Load a problem from a set of sample problems.
  • Load From File - Load a problem from the local disk.
  • Load From URL - Load a problem by specifying a url where the STRIPS problem is located.
  • Save STRIPS - Save the STRIPS problem to the local disk.
  • Print - Prints the canvas as displayed in Solve mode.
  • Quit - Close the STRIPS Applet window.

Edit Menu

  • Undo - lets you undo the last operation if applicable. This is only available in "Create" mode.
  • View/Edit Text Representation - Opens a window containing the text representation of the STRIPS problem. The text can be edited in create mode. The STRIPS problem can be updated from the text representation window by clicking the "Update STRIPS problem" button. With this feature, a STRIPS problem can be indirectly loaded from a  locally saved text file by pasting the text representation of a STRIPS problem to the text representation window.

View Menu

  • Font Size - Set the font size used in the STRIPS problem.
  • Line Width - Set the width of lines displayed in the STRIPS problem.
  • Autoscale - Adjust the STRIPS problem to be fitted in canvas.
  • Pan/Zoom - Select which mode to be in. Then when right-clicking and dragging the mouse on canvas, you can pan or zoom the STRIPS problem on the canvas.
  • Enable Anti-Aliasing - Enables/disables anti-aliasing.
  • Show Message Panel - Show or hide the message prompts above the main canvas.
  • Show Button Text - Show or hide the text on the buttons in the toolbar.
  • Show Buttons - Show or hide the removable toolbar buttons.

Help Menu

  • Legend for Nodes/Edges - Opens a dialog with a legend for describing what the graph shapes/colours mean.
  • Help - Opens this web page, which provides general help on the Decision Tree Learning applet.
  • Tutorials - Opens up the Tutorial web page. Tutorials walk through how to use the applet.
  • About CIspace - Provides brief information about the CIspace project.
  • About this Applet - Identifies the applet version and names of developers.

dot Create Mode

Create a Variable

  • To create a variable, press the "Create Variable" button and click on the white canvas within the "PreConditions" box on the canvas. This will bring up a dialog box where you can enter the name, domain type, and domain values of the variable represented by the variable you're creating.
  • The variable name can be almost anything you want as long as it has no spaces, and no "<", ">". It's best if the variable name is capitalized and starts with an alphabetic character.
  • The default domain type is boolean, and a boolean domain initially consists of {true, false}. To get a different domain type, simply select the appropriate radio button next to "Domain Type:" of the type you want the variable to be. The other domain types are initially empty.
  • When you've selected a domain type you can enter domain values in the text field next to "Domain:". String values can be almost anything; it's best if they have no spaces and contain no commas. Integers must be integers for instance; 1,2,35,10001. Boolean values must be either "true" or "false". An example of how to enter domain values appropriately for the specified domain type is below the text field. Anything entered into the domain values text field will be automatically removed from the domain. Anything between two commas are considered one item.
  • Click "OK" when you are done and the new variable will appear.

Creating an Action

  • To create an action press the "Create Action" button and click anywhere within the "Actions" box on the canvas.
  • A dialog box will pop up where you can enter the name of the action.

Creating a Pre or Post Condition

  • To create a Pre or Post Condition press the "Create Arc" button
  • To create a Pre Condition click on a variable node in the "PreConditions" box and then an action node in the "Actions" box. A dialog box will pop up where you can select the value that Pre Condition is to take. Click "ok" and the Pre Condition has been made.
  • To create a Post Condition click on an action node first in the "Actions" box and then a variable node in the "PostConditions" box. A dialog box will pop up where you can select the value.
  • If, at any time, you want to view the current pre and post conditions for a given action; you can do so by first clicking on the "Set Properties" button and then clicking on the given action.

Selecting/Modifying/Removing Variables, Actions and Arcs

  • You can select and move variables and constraints by pressing the "Select" button and clicking and dragging an entity.
  • You can delete an entity by pressing "Delete" and clicking on variables and constraints. In this manner you can also remove a variable from a constraint by clicking on an edge connecting a variable to a constraint.
  • To modify variable and constraint properties, simply click on them when the "Set Properties" button is selected, and an appropriate dialog will appear.

Editing the Text Representation

  • Sometimes the graphical user interface isn't efficient for creating the STRIPS problem you want. By selecting "View/Edit Text Representation" from the edit menu, you can directly edit the text representation of the STRIPS problem. This is useful if you have many identical domains with lots of elements and you'd like to avoid retyping all the domain elements for each Variable. It's also useful if you want to modify a variable after you've created it. Simply make the changes you want, and then click "Update" to load the new STRIPS problem.

Creating a New STRIPS problem

  • To delete the current STRIPS problem and start with a blank canvas, select "Create New STRIPS problem" in the "File" menu.
  • Loading STRIPS problems:
    • A set of sample STRIPS problems is available for loading from "Load Sample STRIPS problem" in the "File" menu.
    • A STRIPS problem can be loaded from a URL from "Load From URL" in the "File" menu.
    • A STRIPS problem can be loaded from a saved file on the local disk by selecting "Load From File" in the "File" menu.
  • Saving STRIPS problems:
    • The current STRIPS problem can be saved to a file on the local disk by selecting "Save STRIPS" in the "File" menu.

dot Solve Mode

Setting the Horizon Length

  • To set the horizon select the drop down list next to the "Set Horizon" button and select the desired horizon length then press the "Set Horizon" button
  • If the desired length is no available then go to the "Edit" menu and select "Set Maximum Horizon Length". A dialog box will pop up allowing for the desired length to be inputed. After the length is inputed the horizon length may be then set using the above instructions.

Converting to CSP and solving

  • To convert the STRIPS problem to a CSP problem and solve utilizing one of the other CSP based applets click either the "Solve with Arc Consistency" or "Solve with SLS" buttons.

Converting to CSP and saving

  • To convert the STRIPS problem and save as a CSP problem click on the "Save as CSP" button.

Valid HTML 4.0 Transitional